Skip to main content

Tulip 4.0 issues, Mac OSX launch problem and more.

Hi everyone,

It's been almost a week that Tulip 4 has been released and, as we expected, a lot of problems occurred with this new major version of Tulip:

  • A lot of Mac OSX users have been unable to simply run Tulip due to missing libraries errors. Fixing this problem on the client side is not an easy task since it involves installing macports and a lot of other dependencies. The Mac OSX bundle is meant to be standalone without the need to install any other package.
  • Some crashes concerning python have been reported, we are currently working to fix them and to give more feedback to the user if an error with the python installation is found.
  • A lot of minor features about the GUI have been asked for. We are still working on it but the most part should be included into the Tulip 4.1 release.
  • Many crashes, stranges bugs or so have also been fixed since the 4.0 release.

That's why we are going to release Tulip 4.1 before the end of the week. We are great fans the "release early, release often" development philosophy, especially after a new major release.

So be sure to stay tuned on the newsfeed this week to checkout the new Tulip 4.1 release !